Full system restart
Maintenance
Sep 17 at 07:04pm CEST
Email, Identity Provider and HSPS Manager are back up!
Affected services
Updated
Sep 16 at 10:15pm CEST
All systems have been taken down, and the multi hour journey into restoration has begun. Thank you for your patience.
Affected services
Created
Sep 16 at 09:00pm CEST
During this maintenance, ALL of the services listed below will be made unavailable. Through time, systems will come back up one by one. Please bear with us.
Affected services